\\ Home Page : Articolo : Stampa
[Risolto] Installare Moonlight per Firefox 3.6 su Ubuntu 9.10
Di Alex (del 18/02/2010 @ 10:11:28, in Linux - open source, letto 13255 volte)

Click per ingrandire

Premetto che è veramente deprimente che la RAI RADIOTELEVISIONE ITALIANA ignori tutti i suoi telespettatori che usano Linux e non faccia nulla affinchè il sito RAI.TV sia visibile facilmente anche da loro.

[Aggiornamento 18/02/10] Ragazzi io non desisto, ma chi legge magari fornisca un feedback a tutti gli altri soprattutto per raggiungere Mozilla e Novell e fargli stabilizzare questo maledetto plug-in! Vi funziona bene? Dopo quanto crasha? Con quale hardware e versione di Firefox e Linux? Riuscite con un hack a farlo partire su Chrome 4.0? Io non ho mai disinstallato Namaroka (aka Firefox 3.6pre che, se volete reinstallarlo,non dovrebbe sovrascrivere l'attuale final ma affiancarla) col plugin Moonlight 2.0 e riprovandolo ora, il sito RAI.TV non crasha mai (anche se è pesante come al solito!) . Io ho così impostato come home il sito RAI.TV e collocato un bottone sul pannello di Ubuntu col quale apro solo il sito RAI da Namaroka ..e dopo 4 giorni di test, non ha mai crashato!
Questa è la mia icona che dice tutto: Sito RAI.TV fatto coi piedi!

Ma è comunque una situazione inaccettabile. La Rai dovrebbe provvedere e switchare su un player Flash o HTML 5 almeno quando il browser rileva Linux, invece di bloccare chi tenta di visualizzare lo stream al di fuori del portale! La cosa che fa ridere è che banner e spot pubblicitari sono in Flash (e funzionano) . Ecco infine la prova che la versione instabile di Firefox è molto più stabile di quella attuale con Moonlight: ASSURDO! Esco e rientro e non crasha mai! Provate e riferite.

Click per ingrandire


[Aggiornamento 17/02/10]
Probabilmente subissati dalle proteste degli utenti linux, quelli della Novell hanno pensato bene di rilasciare una versione di Moonlight 2.1 (che sembra un po' più stabile) Abbinatela anche con l'ottimo TVClick come spiegato sul sito del Majorana e riavrete i canali RAI su Linux! (TESTATO FUNZIONANTE)

[ARTICOLO DEL 15/02/10]
Fino a pochi giorni fa funzionava perfettamente il programma UbuntuWinTV che consentiva di vedere tutto il bouquet RAI DTT usando l'ottimo VNC 1.0.4. Ora per ogni canale RAI appare l'avviso "La visione del video è consentita solo dal portale RAI.tv" . Peccato che, se provi ad accedere al medesimo con Ubuntu, Firefox 3.6 crasha immediatamente a causa di una implementazione penosa di Microsoft Silverlight "curata" da Novell, chiamata Moonlight 2.0!!! Finalmente, dopo tantissimi tentativi, io sono riuscito a far ripartire questo pessimo plugin e, visto che tantissimi utenti Linux sono imbestialiti per il fatto che non riescono a vedere le olimpiadi invernali, ho deciso di scrivere una breve guida sperando che la cosa funzioni per tutti (con questo plugin, non si può mai dire che sia definitivamente stabile, nel passaggio da Firefox 3.5 a 3.6 sembrava fosse tutto risolto!)

1.Aprite /home/nome_utente/.Mozilla/plugins/ cancellate la cartella moonlight e tutto il suo contenuto. Potrebbe essere necessario attivare su Visualizza "Mostra i files nascosti".

2.Dal menù Sistema->Amministrazione->Gestione Pacchetti cercate Moonlight. Se, come nel caso mio è ancora installato Moonlight 1.0, disinstallatelo completamente.

3.Andate sul sito di Moonlight e installate Moonlight 2.99.0.2 pre-release (aggiornata all' 11 febbraio!)

4.Riavviate Firefox 3.6, andate sul sito RAI.TV e, quando proposto, installate i media codecs 2.0. Fatto!

Come vedete nella immagine sopra, a me la procedura ha funzionato ed ho recuperato la visione via internet di tutti i canali RAI.

PS: Se dopo qualche avvio riuscito dovesse ricrashare (!!), inserite questo link nella barra dei segnalibri, per avere un rapido accesso al plugin Novell. Ogni volta che crasha disattivate il plugin, reinstallate la 2.99.0.2 e riattiavelo. Lo so è solo un workaround temporaneo. Protestate con la RAI!! perchè anche gli script per Greasemonkey non funzionano più. Pensate che bello se fosse in HTML5 magari con opzione OGG/Theora Firefox - H264 Chrome 4.0..

2^ cura di ripristino! Che dobbiamo fare, per l'incompetenza di alcuni!!